HTML PHP Emails Help

Not sure if this is Squirrel Mail's fault or Google's fault, but I've never had this issue prior to using an EHCP server.

After sending PHP emails with HTML content, the HTML format shows up if I login to Webmail through the EHCP panel and download the message as an attachment. The attachment, if opened by my local browser, shows up as an HTML file, and it is properly formatted. However, I'm using Google to download my emails and file them under my Gmail account. After Gmail downloads the messages, it shows up like this:

realEmailRemoved@test.com
date Sun, Jul 17, 2011 at 3:39 PM
subject Pending Registration

hide details 3:39 PM (1 hour ago)

Content-type: text/html; charset=iso-8859-1

From: Me
Message-Id: <20110717223054.39698DC0785@eric-desktop>
Date: Sun, 17 Jul 2011 16:30:54 -0600 (MDT)

After registering your client via your server, please visit the following URL to send them confirmation:

Any ideas? I really need it to show up properly once Gmail downloads the messages, as it takes a long time to login to Squirrel mail and download each message as an attachment.

My PHP Code Headers Look like this:


$headers = 'MIME-Version: 1.0' . "\r\n";
$headers .= 'Content-type: text/html; charset=iso-8859-1' . "\r\n";
$headers .= "From: $uname <$email>";

I haven't changed the script since using this EHCP setup... it's just not downloading properly, and I'm not sure why. Will there be an updated version of Squirrel mail included in EHCP soon? Maybe this is the problem?

Any help would be greatly appreciated.

Also, the email sender shows up as (unknown sender) under Gmail even though the message clearly states who it's from.

~
Thanks
OwN-3m-All
EHCP Force Edition

Any ideas? I'd really like to get this working. My emails have got to be formatted in HTML. Else, I can't do anything with them.

~
Thanks
OwN-3m-All
EHCP Force Edition